52e69bfa0f
From here http://ftp.de.debian.org/debian/pool/main/w/wmmixer/wmmixer_1.6-1.debian.tar.gz as requested by Rodolfo Garcia.
20 lines
362 B
Diff
20 lines
362 B
Diff
This patch includes the optimization parameters for g++
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -6,7 +6,14 @@
|
|
mandir = ${prefix}/share/man
|
|
|
|
CXX = g++
|
|
-CXXFLAGS = -O -Wall
|
|
+CXXFLAGS = -Wall -g
|
|
+
|
|
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
|
|
+ CXXFLAGS += -O0
|
|
+else
|
|
+ CXXFLAGS += -O2
|
|
+endif
|
|
+
|
|
EXTRA_LIBS = -L/usr/X11R6/lib -lX11 -lXpm -lXext
|
|
|
|
|